Paint Effects

Paint Effects

. Paint Effects offers a wide variety of brushes that let you add
real-time effects to a scene. With this toolset, you can work on either
a 2D canvas orin a typical 3D scene. This makes it possible to create

either bitmap images or integrated brush strokes that can be viewed
and animated in 3D. Paint Effects offers a vast library of pre-sets that
make it easy to add effects to your scene with a few brush strokes.

As you learn more, you can also enhance the existing brushes and even

add your own to the library,

Paint Effects Basics

Paint Effects offers 3D artists a number of pre-set brushes ranging from

a simple pen straoke to a complex brush, such as an animated tree
blowing in the wind. The Attribute Editor for Paint Effects has some

274 attributes. With these attributes, YOu can create a number of effects
brushes ranging from an oil or watercolor brush to many animated 3D

brushes such as lightning, fire, hair, and plants.

Visor

Fram the Visor, you can access a
palette of pre-set brushes, When you
select a brush option, the attrihutes
for that brush are transferred to the
Template Brush.

Template Brush
The Template Brush stores the attribute
settings for your next brush stroke. Yeu
can edit a pre-set hrish by selecting it in
the Visor and then changing the various
attributes in the Template Brush window.

Paint Effects
Dependencies

When you select a brush and draw
a Paint Effects stroke in a 3D scene,
you are actually creating a curve
that provides information as to
where the brush will be placed in
the scene. Once the curve is drawn,
Paint Effects creates a stroke

Shape node. This node takes shape
information from the curveShape
node and applies the brush proper-
ties from the Template Brush to it.

CurveShape Node

This node keeps the CV information
for the curve. It defines the shape of
the curve ftself.

Brush Node
This node takes all of the attribute information fram
the current Template Brush, To change attributes of
abrush once it is already painted, you change the
attributes contained in this nade.
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You can access all the Paint Ffects pre-set
brushes through the Visar, Attributas are
aceessed through the Template Brush window,

Paint Scene
You can use any brush to paint on any object. When
You paint in a scene, yaur brush works in 30 Space.

Fainting in a scene also gives you the option to have
your brush animated.

Paint Canvas

In Canvas mode, you can use any brush to paint on
a 20 canvas. You can then save the image nut to an
image file to use a5 a texture map.

Transform Node

This node contains the actual transform
information for the curve. With this node, you can
modify or keyframe any animation or scale the
size of your curve,

StrokeShape Node
The strokeShaps node contains information such as

pressure mapping, sample density smoothing, and
surface offset.

painting in Canvas Mode

Paiﬂt Effects
of the preset

also
preset brushes.
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can be used to paint 2D images or textures using any
brushes, or ones you have customized yoursellf. You can
add blurs or smears fo existing paint on the canvas using

How to Paint on an Object

To paint on an object in Scene mode, you must

it select the object and make it paintable. You can

You can specify the size of yaur
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Painting in Scene Mode

inti de,
When you paint in Scene mode, you paint in 3D space. In Scene mo

i i i hind them. Many of the
paint directly on objects, or in front or behi 1o

you can

i in the s
strokes that you paint in scene mode use the actual lights in th

Scene mode also lets you animate any brush. As e
also have the option to apply a blur or smears to any brus :

Resolution o
This sets how much of your brush detail lel be ]
shown in yaur work window. A thhler setting will
give you the highest display resolution of your brush
stroke, but it will alsa take longar to refresh your
screen. Rendering Paint Effects will be at full reso-
|ution regardlass of this setting.
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canvas by selecting Canvas >

use this application 1o paint objects like hair on a
Set Size.

character or paint trees on a sculpted surface.
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Background Color

You can change the background
colar of the canvas while in
canvas mode by selecting
Canvas>Clear-0

Wrap Image .

Turning on the wrap image feature
gives you the ability to create a
tileable texture.

Step 1: Add Lights to Your Scene  Step 2: Select Yourmqsmct
Create and aim some lights on the object  Selent the object you wantt

Display Alpha paint on,

in your scene.
You have the option to create a mask ¥
channel with any brush stroke,
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Shading _ |
This option allows you to preview your strokes
i gither wireframe, shaded, or texturad modes.
A higher setting will take longer 1o refresh.

Step 3: Make Object Paintable Step 4: Selecta Bruih a:ladﬁ g’amt
Selact Paint Effects > Make Paintable. Select a brush from the Viso
paint on your object.

Blending

Panels
Paint Canvas Brush Camera Resolution Object Shading _Display. EtrukeRe&ash
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Brush Stroke
When you paint in a sceng, you create a
curva that has attached brush information

i h
- "1™ Blending takes the shape or color attributes of a brus
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Selecting a brush in the Visor makes it-your T(-::n-nplateCI
Brush. Right-click over another presst in the Visor an
you are given the option to blend either shape, color,
or the entire brush in varying percentages to your
Template Brush.

hairBlond1

! Blend Brush
50%

Color and Transparency -
The color and transparencvfurthg brush can be set
using the sliders in tha Preview windaw toolbar and

in the Template Brush Editor. treeSimple

and combines those elements into your current brush.
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Brushes

Brushes

he power of painting with Paint Effects is that

brushes contain a large number of attributes
that make it possible to achieve almost any required
effect. In a 3D scene, these attributes are stored with
the brush stroke and can be edited after painting.
Therefore, it is @ good idea to learn the role each
of the attributes plays in the look of a typical brush
stroke. As you learn about the attributes, you will
have more control over your own strokes.

Basic Brush Attributes

Paint Effects works by creating a series of dots along
a curve. When you paint with a brush, the closer the
dots are together, the smoother your brush stroke will
look. Using the Attribute Editor, you can control the
size, color, and spacing of these dots. This method
lets you create many different effects. In the Attribute
Editor, there is a setting called Global Scale. This
setting scales all the attributes proportionately to your
scene. If you paint a stroke that is too big, simply use
a lower value for Global Scale.

Brush Profile Brush Width

YWhen you paint, you are basically creating
round dots along a curve. By opening the
Brush Profile attributes in the Attribute
Editor, you can set how many of these

dots are created and how far apart they
are spaced. By setting Stamp Density,
Brush Width, and Softness you can choose
between a dotted line with harsh edges ar

a soft flowing brush stroke,

Shading

You can shade the Color, Incandescence, and
Transparency of any Paint Effects stroke, In
the Paint Effects window, you will find sliders
that let you change these settings quickly. For
more optiens, you can also open the Template
Brush window ta make changes. Ifyou are
working in 2D canvas mode, you can only
make changes to brush settings before you
paint with them.

Incandescence

lllumination

Every brush stroke can contain lighting
information. In the Template Brush window
you have the option to use real lights from
the scene oryou can chaose to have the
brush be self-it by specifying the position of
the specific light. In the lllumination section
of the Template Brush window, you can also
adjust specular qualities such as Specular,
Specular Power, and Specular Color. By
doing so, you can create a 3D feel to an
otherwise 2D brush stroke.

Specular Power

Paint Effects allows you to create 20 images using a
variety of pre-set brushes. You alsa have the option

to smudge, blur, or add water to your images to cre-

ate interesting effects.
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ghadow Effects

vou have the option to add shadows to your paint
stroke. When using Paint Effects, you can use either
Fake or Real Shadows. Fake Shadows take less time
to render and are usually sufficient for 2D textures or
flat surfaces.

Real Shadows require you to select Cast
shadows from the Attribute Editor, and then turn on
Depth Map shadows for the light you want to cast
shadows. Real Shadows only work in Paint Scene
mode and show up when you render.

Texturing

You can add a texture to a Paint Effects brush
using either a Checker, U or V Ramp, Fractal or File
Texture. This is done by first enabling the Map Color
box in the Template Brush window located in the
Shading section, and then selecting what type of
texture you want to map in the Texture Type box.
You also have an option to choose which type of
Mapping Method to use. You can map the texture to
your stroke using either 2D or 3D methods.

When you enable the Map Color or Map
Opacity, you will notice that as you map a texture
to a stroke, there is a separate color channel for
the texture and for the original shading color. The
original shading color value is still used. When you
map a texture to your stroke, the texture uses the
colors in the texture color section. The texture then
takes the original texture colar and multiplies the
texture color value by the color value. For example,
if you have a stroke that has a Checker mapped to it,
and your original color is black, you will not see the
Checker effect because black equals 0. If you change
the color to white (value = 1), you will see all colors
in the texture section mapped to your stroke.

Mapping Methods

When you map a texture, Maya gives you the option
to use different mapping methods.

Full View Tube2D Mapping 3D Mapping

Full View Mappingmaps ~ Tube2D Mappingmaps ~ The 3D Mapping

your chosen texture your texture along the method wraps the file

across the entire screen part of the stroke that around the actual stroke

vigw, and reveals it is visible to the camera,  in 3D space, as if the

where you paint. projected as if the stroke  stroke were really a
were flat and oriented tube {or in this case,
towards the camera. a snakel,
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Common Values

When you explore some of the many attributes that make up Paint
Effects, you will see some recurring attributes:

Values 1and 2

Certain values have a 1 or 2 beside them. These are values that affect strokes where tubes
are enahled. The value 1 stands for the base of the tube, while 2 represents the tip of the tube.

Dropout

Dropout defines the proportion of the given attribute that is randomly “pruned” to give a more
natural look. For example, a Twig Dropout setting of 0 will produce exactly the same amount
of twigs each time it is created, where a setting of 1 will prune all twigs.

Deéay

This value defines the rate atwhich a factor diminishes for a given atjribute.Fur example,
setting a value of 1for Split Size Decay creates branches the szme size as the bran_ch they are
branched from. Setting a value less than one will produce them smaller than the original.

Rand

Sets the amount of randomization on a given attribute. The larger the Rand value,th_e higher
the variation in values. For example, if Split Rand is 0, branching will occur at equal intervals
along the tube. A higher value will cause the spacing to be more random.

Bias

Bias is used in conjunction with a random value for a given attribute. Setting a vglue far Eias
will push or pull those random values towards the Bias values. Far example, setting a _pusmve
value for Bias will create more wider tubas than thinner ones. A value of 0 will create just as
many wide tubes as thin ones.




Tubes

tube is an object that grows from a stroke path.

To create vegetation, trees, hair, rain, and other
unique 3D brush strokes, you must enable the Tubes
option on a Paint Effects stroke. When you enable
Tubes, a simple stroke sprouts a series of tubes.
Enabling Tubes in the Attribute Editor allows you
to create brushes that simulate vegetation or other
organic growth. The attributes are named after the
parts of a tree and are very similar in their function.
However, the power of Paint Effects is that it allows
you to pick which specific parts of the Tube you want
to use; nothing stops you from using only some of
these elements. The shape of the tube can then be
shaded and lit using the same lighting as vour scene.

Tube Creation

As you paint a stroke, sample points are created along the stroke. The number of sample points on a
stroke depends on the settings you make to the attributes in the strokeShape node. At each sample point
a new tube can be created and any existing tubes will grow a new segment. These segments can then '
become branches, twigs, leaves, flowers, or buds. By setting different attribute combinations, the tubes

can grow into an infinite number of shapes and sizes.

Tube Width2a ——

Tube Width1

\ 

Tube Shape

At the most basic level, the shape of a tube is deter-
mined by Tube Width 1 and 2 values, which set how
thick the tube will be at the base and the tip, respec-
tively. Other attributes that affect the shape of a tube
are Twist, Flatness, Noise, Wiggle, and Curl.

'-\r.\
\

Low Tube per Step

Tube Density

Density is dependent on the Tubes per Step
attribute. Increasing the value of this attribute
creates more tubes at each sample point along
the curve.

Tube Length Max /

Tube Length Min

Tube Size

The attributes Length Min and Length Max determine
the minimum and maximum length that a tube can
be. A brush with a big difference in these values will
create a stroke with tubes that are quite varied

in height.

Use Normals Use Path

Tube Direction

Tube Direction specifies whether the tubes use the
Normals or path direction. If you use the Normals,
you can then set the Elevation and Azimuth, which
will determine the direction the tubes point. If you
use Path Direction, the tubes will try to follow the
path of the curve you paint,

Growth

Growth is used to grow the tubes over time and
have them sprout branches, twigs, leaves, flowers,
and buds. Adjusting the attributes in each of these
subsections allows you to simulate many natural,
and some unnatural effects. Much like a shading
network, it is a good idea to consider the various
material qualities you want to achieve in advance.
For example, if you understand how a plant looks
and behaves, you will find it easier to translate these
into the various Paint Effects growth attributes.

Working With Paint Effects Tubes

Through the use of tubes, you can create a large
number of effects such as rain, lightning, sparks, and
fire. In most cases, you will pick a pre-set brush and
then modify the attributes to fit into the look of your
scene. When you paint a stroke into your scene, you
generally paint the stroke onto your targst surface.

Rain Stroke
Rain
To creata rain for this scene, the pre-set Rainl
Lirush was usad and a stroke was painted
along the street. The only attribuie that was
modified was the gap spacing, which, in this
tase, allowad the "amount” of rainfall to be

adjusted. To place the rain, a curve was drawn

on the streat directly.

Sparks

The sparks were created by using the default
pre-sat sparkExplosion brush and creating
two small strokes near the wires coming out
of the transformer. The sparks were then

set to animate only after the lightning hit, by
turning on the clip time attribute in the flow
animation section and by setting the time
that the sparks were to oceur.

Spark Strokes

Branches

The number of branches
created at each split is
determined by Mum Branches

Twigs
Twigs sprout from branches
or whes.

Leaves
Leaves sprout from @ twig or
a branch.

Flowers
Flowers grow in & radial
pattern around tubes or
branches.

Buds
Buds sprout from the tip nf &
pranch or twig.

Lightning

Leaf Texture
Afile lexture is used to Textu

texture has an alpha channel,

make it transparent automati

Control Curve

To create lightning, a small strole using the Lightning3
pre-set brush was made near the top of the transformer.
A short single stroke was used to make sure that there
wolld be only ane holt of Tightning. The shading and
glow attributes were set to a white and blue to create
the bhuish glow, Finally, a control curve was used to
direct the lightning ta the desired angle in the sky.

Fire

Firg was created using a standard fire pre-set
brush. A curve was drawn along the top of the
transformer. then Global Seale was increased to
create flames that matched the size of the trans-
furmer and the scene. The smake was created
using the basic risingSmoke2 brush. The animation
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of the flames is generated by turbulence forces

that were built into the fire effects.

Fir[e Stroke




Brush Stroke

Brush Stroke

When you draw a brush stroke with a pressure-sensitive graphics
tablet and pen, you modify parts of the stroke based on how
hard you press as you paint. In Maya, this information is retained in the
strokeShape node and offers another way of controlling how the brush
information appears when rendered. In 3D scenes, you can turn curves
into strokes and apply brush settings. You can also capture the brush
attributes from any brush and create your own pre-set for |ater use.

Stroke Attributes

Strokes are the curve that the Paint Effects brush is applied to. When
you paint, you will notice that painting very slowly produces a result
very different from painting quickly, since there are more sample points
along the stroke. In this respect, your stroke acts much like a paint
brush on a real canvas. Setting attributes in the strokeShape node
affects the position and number of tubas that are contained on

a particular curve.

Low Sample Density

High Sample Density

Sample Density

Asample paint along a stroke either starts a tube or grows a lube by ona seg-
ment. Ifyou draw a stroke slowly or with heavy pressure, there will be many
mare sample points in a given length as opposed to a curve that was drawn
quickly or with light pressure. Increasing the sample density on the stroke that
was drawn quickly can help make the brush look more similar to the ane that
was drawn slowly.

Normal Direction

applied instead.

Offset =10

Offset=5

Offset=0

Cffset

The affset lets you set a value that will paint the brush at a distance away from
the surface you ara painting. For example, if you want to place some clouds in
the sky, you could use a cloud brush with a high value for offset and paint on the
ground plane. This will put your strake on the surface, but your brush will actually
paint the clouds away from the stroke.

Smoothing

Painting Curves

The power wires in the above image were created

nat with geometry, hut with curves that have the
default template brush stroke applied.

When you create a stroke on the ground plane, the Use Normal attribute is
automatically tuned on and set to the Up Vector. You can change this setting
and have the Normals paint in either X, ¥, or Z directions, Any tubes contained
on that stroke will grow in the selected direction, When you paint on an object,
the Use Normal is tmed off and the surface Normal of the geometry is

?
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Smeothing allows you to dampen the values between Cs on a curve to create
asmaother path for your stroke. With enough smaothing, it is possible to create
a straight line out of even the most drastic curve.

pressure Mapping o _
The strokeShape node also contains pressure mapping mformatio-n.

f you use @ graphics pressure sensitive tablet, up to 3 brush-crea’:h:)nk
ttributes can be mapped to the pressure used on the t(::\b'let as a stroke
?5 drawn. You can access these settings by selecting Paint Effects >

paint Effects Tool - option.

Transparency

Num Leaves Tubes per Step

How to Put a Brush on a Selected Stroke

You can apply any brush to any curve or Paint Effects §troke in your
scene. This is useful for using the same brush on multiple curves
without having to paint each stroke.

L_| pens

| AL
) underwater
7] watercolor

Step 2: Load to Template Brush
Open the Visor and select the desired brush
1o |oad it into the Template Brush.

Step 1: Select the Stroke
In your seene, select the stroke curve.

Faril Elfects Tod
Miake Fainlzbis
Tarrplate Bruth Seltngt. .
Flaset Torplale Brush
¥ Flari on Panlabls Dtiscts
FntanView Flane i
Fingly Saltings 1o Laat Sheke
el Seliings Irom Selacted Siioke
gy e 10 e
Share One Bush
Remove Biush Shaing
Seloct Buch Name: Cortaning..
fush eimation
Corve Ulins
Fani Elfect: Blobals...
Fresel Blerding
Save Bith Presal.,

: Render Your Scene
Step 3: Apply the Brush Step 4: r
In th«I:Pamt I?flfjects menu, select Paint Effects > Add lights to your scene and then render.
Apply Settings to Selected Strokes
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Comhbining Mappings _
Prassure mapping becomes most effective when
yau combine different mappings to simulate an
actual paint stroke. For example, the strokg to
the left uses scale and transparency mappings.
Pressing hard on the tahlat gives you a thir.k dark
stroke, while prassing lightly gives you a thin,

wispy stroke.

Softness

\

Hard Soft Pressure
Pressure Stroke
Stroke

How to Create Your own Pre-set Brushes

Once you have created a brush that you are happy _
with, you will want to save it so that you can use it in
the future. Maya lets you customize your workspace by
saving your brush to either the Visor or the Shelf.

Step 1: Edit Brush Attributes
Edit the brush attributes in the Attribute
Editor or Channel Box to get a brush
you like.

P Ellests
Viaka Pk
Tarplats Bich Sorgi Cilk
Raet Tengisla s
 Pei o Partable Objects
Pl Vi P
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Shara Gra B
Femave Brush Shereg.
Select Bl Heomes Golaeig...
Bushsidian
Cuive ikes PO
Pk Efects Gl
Fiosot bkodra.

Step 3: Save Preset

With the brush loaded into the
Template Brush, select Paint Effects >
Save Brush Presets.
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Step 2: Load to Template Brush
Select Paint Effects > Get Settings from
Selected Stroke. This will load the brush
into the Template Brush.

ety Ll - fmgiboem
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Step 4: Grab Icon _

Switch to the Paint Effects preview
window by pressing “8" on the keyboard.
\With your brush rendered, select Grab
|con and clicksdrag an area around the
brush to create an icon.
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Cloth

Cloth [aA

LUNLIMITED

With Cloth, you can create realistic animated cloth within the Maya
environment. Cloth gives you the ability to model garments for
any animated 3D figure, apply dynamic effects, and simulate the

cloth behavior.

If you are creating a simple piece of cloth like a sheet or tablecloth,
you can create a polymesh or NURBS shape and make it a cloth object.
Alternatively, attaching panels together for constructing a garment is

similar to the way a tailor makes clothing.

Cloth Animation

Cloth simulations are driven by dynamic solvers; there are no
keyframes. A number of constraint types in Maya allow you to restrict
the movement of your character’s clothing. Collision constraints let
your character's clothing move with the character’s body.

Cloth objects

A cloth object is a piece of geometry simulated as
cloth. You create cloth objects from polygonal shapes
or NURBS shapes. The original shape is hidden and
the tessellated cloth shape is displayed. The original
shape and the cloth shape are grouped under the
object’s transform.

With NURBS objects and certain procedurally-
generated polygonal objects, you can get artificial
stress lines caused by the regular tessellation. If you
change the topology of the polygonal object after
simulating, you have to resimulate.

Garments

A garment is one or more panels that are seamed
together to form a cloth. A panel is made up of two or
more NURBS curves that are on the same plane and
form a closed region.

When you create a garment from curves, Cloth
creates a mesh with varying sizes of triangles that are
randomly distributed. The mesh has no regularity or
stress lines. This creates more natural folds.

In addition, if you change the resolution of a
garment after simulating, Cloth can update the geo-
metry without resimulating. However, you need to
simulate for the cloth to move with the new resolution.

Collision Objects

In order for your cloth to drape over your model

or an object, you need to make it a collision object.
When you make an object a cloth collision object,
Maya connects it to the cloth solver and adds three
collision object attributes.

Polygonal objects, NURBS, and Subdivision
Surfaces can all be used as collision objects. If your
model is a NURBS object or a Subdivision Surface,
Maya automatically converts it to polygons when
you make it a collision object.

Dress-up Pose

It is recommended to start the cloth simulation from
a dress-up pose. This will eliminate any self-collision
of the garment worn by the character, and minimize
wrinkling in the initial fitting of the garment.

To create a character animation, you should
move your character from the dress-up pose to the
position it will be in at the start of the animation.
You may want to add some frames to the start of
your scene to accommaodate this transition, or, the
cloth might not react as expected.

Draping and fitting

After you create the garment, you drape it and fit it to the character.
To drape the garment on the model, you specify the model as a

colli
the model.

sion object and use the cloth solver to drape the garment over

Fitting involves modifying the ariginal garment to accommaodate

peculia

rities of the character on which it is draped. You can influence

how the cloth settles on the character using constraints and dynamic
fields. For example, you can pull out wrinkles or pin portions of the
garment to specific places on the character. You can assign different
properties to the panels and set various attributes of the cloth to
change the physical behavior of the cloth.

Once the garment has settled, you can save this initial position of

the garment and hegin animating.

Simulate Cloth

Orice you have your cloth ready to drape over your character, you can
start the simulation. The simulation is performed by the cloth solver,
which assembles information on all the garments, cloth objects, bodies
they interact with, and any fields or constraints applied to the cloth.

Cloth Cache

When you simulate cloth by playing through the Time Slider, Cloth
creates a cache file to store all the positions of the vertices of

the cloth. The cache lets you quickly preview the results of the cloth
simulation without having to render to a flipbook. This offers many
benefits, including scrubbing back and forth in the Time Slider and
re-using a cache so you don't have to solve at render time.

Intersecting NURBS Curves

Step 1

The cloth abject begins as a series of intersecting
MURRS curves that form the front and back shape
of the shirt.

Step 3

Mext, one pane! is defined by using Cloth > Create
Garment. Seams are created where each panel
overlaps. This creates a “cage” around the model
and a polygonal “cloth mesh.”

Cloth Panel lcon

Step 2
Panels are defined for the different regions of the
shirt by selecting Cloth > Create Panel.

Step 4

The body geametry is made into & collision ohject by
selecting Cloth > Create Collision Object. At this

paint, no dynamic interaction has oveurred between
the cloth object {shirt] and the collision object (body).
Therefore, the cloth appears very loose.
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Cloth Constraints

Sometimes you may want to constrain certain parts
of your clothing to your character so they don't fall
off. You can do this using constraints. For example,
you can use constraints to make sure the pants of
your character stay on, or to keep straps in a dress
attached to the shoulders. In addition, you can use
constraints to pin clothing together or attach items
such as buttons or pockets.

Dynamic Fields

Because Cloth is fully integrated with Maya, you

can use Maya's dynamic fields to affect the motion
of your cloth. You create the field the same way

you create a field in Maya. You connect the field

to cloth using a type of constraint known as a field
constraint. You can connect field constraints to cloth
vertices or panel curves.

The mode! with the final cloth
shape after the simulation.

Step 5

Select Simulation > Start Simulation to perform
the cloth simulation. Maya applies gravity to the
¢lth. Based on the cloth properties set by the
user, the clath collides, interacts, and settles to
take shape around the body.




